squealing screeching? but no lack of performance??

General Savage Discussions.

Moderator: Moderators

Post Reply
thebullx88
Savage Newbie
Savage Newbie
Posts: 9
Joined: Thu Mar 26, 2015 11:00 pm
Location: longIsland

squealing screeching? but no lack of performance??

Post by thebullx88 » Sun Apr 26, 2015 10:37 pm

Hey guys I have savage xl brushless I have ran the trcuks numerous times now and it runs great! I run it on 4s with alza center diff with 48 / 13 gearing so my problem I had out today was the truck was making a really loud squealing or screeching sound but no lack of performance what so ever hitting top speed as usual and ripping wheelies..i did some searching only thing I could find was people saying dog bones because they here it when they lift each suspension arm but that dosent happen in my case only when trucks Is under power. spinning wheels freely while not juiced I don't hear a thing. let me know what you guys think

thanks kurt

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
scrogg
Savage Extraordinaire
Savage Extraordinaire
Posts: 5675
Joined: Fri Oct 07, 2005 11:00 pm
Location: N. Augusta S.C.
Contact:

Post by scrogg » Tue Apr 28, 2015 12:58 am

Check the brakes for binding, they may be adjusted too tight or too loose causing a binding issue. Brake pads could be worn out, or you have bearings somewhere in the drivetrain worn out. It could be something else entirely but those are my first "go to" items..
Old nitro junkie with a Flux xs

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests