bad batteries at mybatterysupply.com

This forum is dedicated to discussion regarding the HPI E-Savage.

Moderator: Moderators

Post Reply
User avatar
TreeCat
Savage Novice
Savage Novice
Posts: 52
Joined: Sun Aug 05, 2007 11:00 pm

bad batteries at mybatterysupply.com

Post by TreeCat » Sat Sep 08, 2007 11:59 pm

I purchased some batteries from mybatterysupply.com. They were supposed to be for my rc car. 4200 mAh 7.2 volt with tamyia connectors. 4 of them and they were about 110. Not cheap price, but I figured it would be worth it. They sent me the wrong batteries. I got same voltage and capacity, but diffent shape. I emailed them and they said I would have to just return them, I could not exchange them. SO, I go to the returns and there is a 20% restocking fee. I email back and ask if this is the case, as I got the wrong batteries and I just want to exchange them. Yup. you blew it by shopping with us, I guess they were trying to say. So, I emailed back and said you just lost a cutomer. Ok, now I figure, maybe these will fit if I jam them in, just a little. They are almost the same shape. I need the 2 stacks of 3, but got the 6 side by side. So I am just prying the cover off the side of the e-Savage and barely pushing the batteries and they come apart. No shrink wrap, just some lame hot glue that did not even bond at all to the slippery plastic covers on the batteries. Anyways, I slightly bent the rest of them and they just came apart. One of them even had a tab hitting the ground right by the pos terimial. I swear, what a crappy job. And this is what they do for a living. SO, I just took them all apart, soldered them into the right configuration and then JB welded them together, then used shrink tube on it. Now they are properly assembled. What a terrible company, do not buy anything from mybatterysupply.com

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Jamiesavage
Savage Extraordinaire
Savage Extraordinaire
Posts: 1908
Joined: Sun Mar 05, 2006 12:00 am
Location: Colombo, Sri Lanka
Contact:

Post by Jamiesavage » Sun Sep 09, 2007 4:04 am

[img]http://i40.photobucket.com/albums/e236/Jamiesavage/Signature.gif[/img]
[img]http://www.sloganizer.net/en/style5,Jamiesavage.png[/img]

Proud member of PXP Racing (www.pxpracing.com)
I'm SavageKilla!

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
KiZ
Site Moderator
Site Moderator
Posts: 5404
Joined: Mon Mar 20, 2006 12:00 am
Location: San Francisco Bay Area

Post by KiZ » Sun Sep 09, 2007 4:59 am

[url=http://www.kizzard.net/gallery/][img]http://i141.photobucket.com/albums/r56/kizzzard/gray-sav.gif[/img][/url]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Nelio
Savage Newbie
Savage Newbie
Posts: 31
Joined: Sun Mar 12, 2006 12:00 am
Location: Portugal

Post by Nelio » Fri Nov 23, 2007 7:37 pm

Hi!!
It is possible to run a stock e-savage with a li-po 14.4V? the speed controller works with 14.8v direcly, not 7.2+7.2?

Thanks
HPI Savage 25 Limited Edition (X)

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
sawmmie
Savage Extraordinaire
Savage Extraordinaire
Posts: 558
Joined: Sat Aug 12, 2006 11:00 pm

Post by sawmmie » Sun Dec 16, 2007 3:14 pm

its good as gone if you run that!
Wanna mess?

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Nelio
Savage Newbie
Savage Newbie
Posts: 31
Joined: Sun Mar 12, 2006 12:00 am
Location: Portugal

Post by Nelio » Sun Dec 16, 2007 6:45 pm

sawmmie wrote:its good as gone if you run that!

What do you mean? it will burn out?
Will not work with this configuration?
HPI Savage 25 Limited Edition (X)

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
sawmmie
Savage Extraordinaire
Savage Extraordinaire
Posts: 558
Joined: Sat Aug 12, 2006 11:00 pm

Post by sawmmie » Sun Dec 16, 2007 7:09 pm

yes it will, there is too much power in those batts, i run an 11.1 volt lipo in my 18th scale with a mamba 25 esc...

so think about it...
i think it would fry!
Wanna mess?

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Nelio
Savage Newbie
Savage Newbie
Posts: 31
Joined: Sun Mar 12, 2006 12:00 am
Location: Portugal

Post by Nelio » Sun Dec 16, 2007 7:17 pm

sawmmie wrote:yes it will, there is too much power in those batts, i run an 11.1 volt lipo in my 18th scale with a mamba 25 esc...

so think about it...
i think it would fry!

Thanks a lot!! So, may be a should use NiMH.... I'm gonna check :P
HPI Savage 25 Limited Edition (X)

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
sawmmie
Savage Extraordinaire
Savage Extraordinaire
Posts: 558
Joined: Sat Aug 12, 2006 11:00 pm

Post by sawmmie » Sun Dec 16, 2007 7:34 pm

i would do that
Wanna mess?

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
KiZ
Site Moderator
Site Moderator
Posts: 5404
Joined: Mon Mar 20, 2006 12:00 am
Location: San Francisco Bay Area

Post by KiZ » Mon Dec 17, 2007 10:08 am

Nelio wrote:Hi!!
It is possible to run a stock e-savage with a li-po 14.4V? the speed controller works with 14.8v direcly, not 7.2+7.2?

Thanks


It will run just great with 14.8v, I don't believe Sawmmie actually knows what he is talking about :p
[url=http://www.kizzard.net/gallery/][img]http://i141.photobucket.com/albums/r56/kizzzard/gray-sav.gif[/img][/url]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
sawmmie
Savage Extraordinaire
Savage Extraordinaire
Posts: 558
Joined: Sat Aug 12, 2006 11:00 pm

Post by sawmmie » Mon Dec 17, 2007 6:20 pm

i do man! i run lipo in my 18th scale, man come on, i know my electrics, run the 14.8 and be happy with it, get some nice batteries, and knock it dead!
Wanna mess?

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Nelio
Savage Newbie
Savage Newbie
Posts: 31
Joined: Sun Mar 12, 2006 12:00 am
Location: Portugal

Post by Nelio » Thu Dec 20, 2007 9:00 am

Hi people!!
I tried with li-po 14.8v and it works great, but not so good as with 2 x 7.2V NiMH, just because of the internal resistence in li-po!! Low "direct" current!! Maybe because of the quality of li-po, chinese and cheap one :roll:
My project is running well... I have to do a topic with it.. but my litlle problem is to translate everything to english, but I will try, hope you understand than :P
HPI Savage 25 Limited Edition (X)

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
KiZ
Site Moderator
Site Moderator
Posts: 5404
Joined: Mon Mar 20, 2006 12:00 am
Location: San Francisco Bay Area

Post by KiZ » Thu Dec 20, 2007 10:22 am

Nelio wrote:Maybe because of the quality of li-po, chinese and cheap one :roll:


I imagine that is the case. Good lipos will have 20-30C discharge and be able to deliver massive current. Of course they also cost a lot :p

Look at maxamps.com for high quality lipos, or look out for thunderpower, hyperion and apogee lipos.
[url=http://www.kizzard.net/gallery/][img]http://i141.photobucket.com/albums/r56/kizzzard/gray-sav.gif[/img][/url]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Nelio
Savage Newbie
Savage Newbie
Posts: 31
Joined: Sun Mar 12, 2006 12:00 am
Location: Portugal

Post by Nelio » Sat Dec 22, 2007 5:51 am

KiZ wrote:
Nelio wrote:Maybe because of the quality of li-po, chinese and cheap one :roll:


I imagine that is the case. Good lipos will have 20-30C discharge and be able to deliver massive current. Of course they also cost a lot :p

Look at maxamps.com for high quality lipos, or look out for thunderpower, hyperion and apogee lipos.

maxamps.com have great li-po... but the prices... but, it's life!! If you want it good, you have to pay for it :P
HPI Savage 25 Limited Edition (X)

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests