got my e-savage yesterday

This forum is dedicated to discussion regarding the HPI E-Savage.

Moderator: Moderators

Post Reply
User avatar
ice_man320
Savage Newbie
Savage Newbie
Posts: 11
Joined: Fri Jul 02, 2004 11:00 pm

got my e-savage yesterday

Post by ice_man320 » Wed Jan 16, 2008 9:11 pm

I got my e-savage yesterday and got it out of the box and was a little disappointed, cause I thought that It would be as big as my nitro savage. anyway I took it out this morning before I went to work and it goes pretty good. I might get some bigger pinion gears to try to get a little more speed out of it but it was fun. oh did I mention that one of my battery packs got fried.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
GONE_DSM
Savage Superstar
Savage Superstar
Posts: 403
Joined: Sat Jan 05, 2008 12:00 am
Location: Sedro Woolley WA
Contact:

Post by GONE_DSM » Wed Jan 16, 2008 10:14 pm

post some pics of the difference in sizes i have been thinking about getting one. thanks

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
iceman320
Savage Novice
Savage Novice
Posts: 91
Joined: Sat Sep 08, 2007 11:00 pm

Post by iceman320 » Wed Jan 16, 2008 11:59 pm

ok I will try to get some pics of my savage 25 and my e-savage side by side posted this weekend.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Vroom
Savage Extraordinaire
Savage Extraordinaire
Posts: 2175
Joined: Mon Nov 13, 2006 12:00 am

Post by Vroom » Thu Jan 17, 2008 12:20 am

How did you fry a battery? Pics would be nice. Of the carnage and the E-Savage. :lol:
[img]http://i118.photobucket.com/albums/o91/Oregonmud/savage-ad.jpg[/img]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
iceman320
Savage Novice
Savage Novice
Posts: 91
Joined: Sat Sep 08, 2007 11:00 pm

Post by iceman320 » Thu Jan 17, 2008 12:24 am

I don't know how the battery fried I was just running the e-savage this morning and I noticed that the end of one pack was glowing red and then the truck just came to a stop. and when I went to see what was wrong I could see the the pack and melted plastic end and the metal thing the connects the two batteries together. I will have some pics up by the week end for you guys to see.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Vroom
Savage Extraordinaire
Savage Extraordinaire
Posts: 2175
Joined: Mon Nov 13, 2006 12:00 am

Post by Vroom » Thu Jan 17, 2008 12:32 am

Your lucky none of the electronics got fried. I wonder if it was the battery or the truck?
[img]http://i118.photobucket.com/albums/o91/Oregonmud/savage-ad.jpg[/img]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
iceman320
Savage Novice
Savage Novice
Posts: 91
Joined: Sat Sep 08, 2007 11:00 pm

Post by iceman320 » Thu Jan 17, 2008 9:10 pm

I think it was the battery because i went out and ran it again this morning with two 1500mah packs and they didn't fry or anything. thy just don't last very long they only last for about 10 min in the e-savage.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Vroom
Savage Extraordinaire
Savage Extraordinaire
Posts: 2175
Joined: Mon Nov 13, 2006 12:00 am

Post by Vroom » Thu Jan 17, 2008 9:24 pm

You can get bigger batteries or change the gearing to get better runtimes.
[img]http://i118.photobucket.com/albums/o91/Oregonmud/savage-ad.jpg[/img]

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
iceman320
Savage Novice
Savage Novice
Posts: 91
Joined: Sat Sep 08, 2007 11:00 pm

Post by iceman320 » Sun Jan 20, 2008 8:24 pm

here are the pics that I promised of my e-savage next to my savage 25 http://www.rcpics.net/img/87727

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
hrddrv
Savage Newbie
Savage Newbie
Posts: 12
Joined: Tue Jan 22, 2008 12:00 am

Post by hrddrv » Wed Feb 13, 2008 7:48 am

they will be diff sizes, the nitro is an 8th and the E is a 10th

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Naossoan
Savage Superstar
Savage Superstar
Posts: 433
Joined: Thu Jan 05, 2006 12:00 am

Post by Naossoan » Fri Feb 22, 2008 12:53 am

Why would you think the e-savage is the same size as a nitro one? The nitro savage is 1/8 scale. E-Savage is 1/10 scale. That's pretty self explanitory.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
iceman320
Savage Novice
Savage Novice
Posts: 91
Joined: Sat Sep 08, 2007 11:00 pm

Post by iceman320 » Sun Oct 05, 2008 3:57 pm

hey guys it's been a while. so I'm trying to get a brushless system setup in my e-savage i have the motor and the esc. But I have been looking at batteries mainely the lipo ones and man they are expensive and i wanted to know how many times can you charge these lipo batteries before you have to buy new one's again? thanks

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
troy8481
Savage Extraordinaire
Savage Extraordinaire
Posts: 615
Joined: Wed Jul 30, 2008 11:00 pm
Location: augusta ga

Post by troy8481 » Sun Oct 05, 2008 10:04 pm

hey iceman put some deans plugs on your setup and get some bigger batteries. i have 4200's and it hauls. i just need to put a fan on the esc and some heatsinks on the motors.  let me know how your brushless works cause i want longer run times. i have a makita 18 volt lithium ion drill and i use it every day at work. bet i have hundreds of charges on the batteries.

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests